easyVDR Kopie des easyVDR-Forums zum Nachschlagen
Hyperion und easyVDR 3.5

easyVDR - >VARforumsname - >Hyperion und easyVDR 3.5

videopix  16.Feb.2018 17:37:11
Hallo,

ich habe easyVDR 3.5 am laufen und wollte jetzt Ambilight nachrüsten. Habe mich nach der [url=http://wiki.easy-vdr.de/index.php?title=Ambilight]Anleitung im Wiki gerichtet. Auf LXDE habe ich im Setup umgestellt. Den Arduino-Sketch habe ich unter Windows aufgespielt. Installation von Hyperion, openjdk-7-jre und HyperCon klappten klaglos. Beim Start von HyperCon bekomme ich allerdings:
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/hyperion/hypercon/Main : Unsupported major.minor version 52.0
       at java.lang.ClassLoader.defineClass1(Native Method)
       at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
       at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
       at java.net.URLClassLoader.defineClass(URLClassLoader.java:442)
       at java.net.URLClassLoader.access$100(URLClassLoader.java:64)
       at java.net.URLClassLoader$1.run(URLClassLoader.java:354)
       at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
       at java.security.AccessController.doPrivileged(Native Method)
       at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
       at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:312)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
       at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)


Weiß jemand Rat?

Ohne gespeicherte Konfiguration gibt dann Hyperion auch gleich auf: 
hyperion-x11:
       version   : V1.03.3 (brindosch-2fbbcff/2f01dfa-1495880388
       build time: Jun  3 2017 02:06:03
X11GRABBER ERROR: Unable to open display. DISPLAY environment variable not set


Mein Board läuft mit einer Intel-Grafik. Da brauche ich soweit ich das verstehe ja keine weiteren Plugins. Wie genau muss das Config-File heißen?

Viele Grüße,
Uwe
Test-VDR: Asrock J4205, 4GB RAM, 30GB SSD, Cine S2 PCIe twin Tuner + DuoFlex an Durline UK119 SCR LNB
gb  16.Feb.2018 17:41:05
Hallo Uwe

Da muss ich auch erstmal schauen, ist schon ein paar Tage her wo hyperion & hypercon bei mir liefen. :)

Ich melde mich wieder.

Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
gb  16.Feb.2018 18:23:54
Es schaut nicht gut aus, daher werde ich wohl die Tage das Wiki anpassen können.

Für HyperCon wird nun openjdk-8-jre benötigt, was auf ubuntu 14.04 nicht mehr tut. Toll das die Jungs von hyperion nicht mal auf ihrer Seite darauf hinweisen.

Daher kannst du nur mit Hyperion NG weiter machen ( PS: Hyperion NG ist eh besser )
http://www.easy-vdr.de/thread-16715-post-178231.html#pid178231

Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
gb  17.Feb.2018 11:04:35
Guten Morgen, ich habe nochmal drüber geschlafen.

Du könntest auch ein hyperion konfig File mit Windows erstellen. Wenn dir hyperion lieber ist als hyperion NG.
HyperCon.jar sollte ja auch unter Windows laufen.

Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
videopix  18.Feb.2018 11:22:49
Hallo Aaron,

danke für die schnelle Rückmeldung. Ich habe Hyperion NG nach der Anleitung problemlos installieren können und die LEDs flackern schon. Die Konfiguration über Browser ist sehr praktisch. Jetzt muss ich nur noch ein paar mechanische Probleme lösen. Der Bildschirm steht in einer Zimmer-Ecke...

Viele Grüße.
Uwe
Test-VDR: Asrock J4205, 4GB RAM, 30GB SSD, Cine S2 PCIe twin Tuner + DuoFlex an Durline UK119 SCR LNB
gb  18.Feb.2018 11:31:26
Hallo Uwe

..danke für deine Rückmeldung, dann werde ich das Wiki auf hyperion ng ändern.

Du bist ja nun die 3te Person, welche mir bestätigt, das es mit dem NG howto funktioniert.


In einer Ecke wird's ein wenig schwer mit dem Ambilight, gerade oben und unten, da ja der Abstand zur Wand immer größer wird, desto mehr es zur Mitte geht.
Sollte du da was brauchbares zustande bekommen, würde es mich freuen ein paar Feedbacks zu lesen.

Gruß Aaron

PS: hast du diesen Teil schon gelesen..
link
Hier bin ich nochmal etwas genauer auf ein paar Einstellungen eingegangen.
Vielleicht hilft es dir ein wenig bei der Konfiguration.


Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
videopix  20.Feb.2018 14:19:54
Hi Aaron,

besonders die Info, dass ich die RGB-Typ-Reihenfolge auf BRG stellen muss war sehr hilfreich. Jetzt stimmen die Farben.
Allerdings bleibt Hyperion NG immer mal hängen. Die LEDs bleiben dann dunkel, der Job läuft aber noch und braucht nahezu 100% CPU. Wenn ich Hyperion restarte ist wieder alles ok. Mein VDR läuft normalerweise durch. Ich schalte mit dem TV nur die Stromversorgung für die LEDs aus. Der Arduino bleibt über USB aktiv.

Ist der Fehler bekannt?

Grüße,
Uwe
Test-VDR: Asrock J4205, 4GB RAM, 30GB SSD, Cine S2 PCIe twin Tuner + DuoFlex an Durline UK119 SCR LNB
gb  20.Feb.2018 17:00:43
Hallo Uwe
Allerdings bleibt Hyperion NG immer mal hängen. Die LEDs bleiben dann dunkel, der Job läuft aber noch und braucht nahezu 100% CPU.
Ähm, nein das ist neu.

Wann bleibt er hängen, im normal Betrieb oder beim Boot?

Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
videopix  20.Feb.2018 17:13:37
Im normalen Betrieb läuft alles. Ich schalte dann den Fernseher und die LED-Stromversorgung aus. In der Regel läuft nach dem Einschalten auch alles normal weiter inkl. LEDs  Manchmal geht nach einigigen Stunden die Last aber auf 100%. Wenn ich den Bildschirm wieder einschalte sind die LEDs dunkel. Nur Restart von Hyperion NG hilft. Wenn der Fernseher an ist, ist mir das noch nicht passiert.
Test-VDR: Asrock J4205, 4GB RAM, 30GB SSD, Cine S2 PCIe twin Tuner + DuoFlex an Durline UK119 SCR LNB
gb  20.Feb.2018 17:18:11

Ich schalte dann den Fernseher und die LED-Stromversorgung aus. In der Regel läuft nach dem Einschalten auch alles normal weiter inkl. LEDs  Manchmal geht nach einigigen Stunden die Last aber auf 100%.

Ah ok, muss ich mal probieren. 
Wenn der VDR bei mir läuft, ist der TV in der Regel bei mir immer an.

Was sagt denn das syslog zu dem Ganzen?

Grüße Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
videopix  20.Feb.2018 21:25:51
Hallo nochmal,

wenn ich das richtig sehe, ist das die entscheidende Stelle im Syslog:

Feb 20 05:39:01 VDR CRON: (root) CMD (   && && && /usr/lib/php5/sessionclean /var/lib/php5 $(/usr/lib/php5/maxlifetime))
Feb 20 05:41:38 VDR kernel: [24738.166113] lirc_serial: ignoring spike: 0 0 5a8ba702 5a8b4e02 4317d 627db
Feb 20 05:41:38 VDR kernel: [24738.166156] ch341-uart ttyUSB1: usb_serial_generic_write_bulk_callback - urb stopped: -32
Feb 20 05:41:38 VDR kernel: [24738.166169] ch341-uart ttyUSB1: usb_serial_generic_read_bulk_callback - urb stopped: -32
Feb 20 05:41:38 VDR kernel: [24738.166310] ch341-uart ttyUSB1: usb_serial_generic_write_bulk_callback - urb stopped: -32
Feb 20 05:41:38 VDR kernel: [24738.166320] ch341-uart ttyUSB1: usb_serial_generic_read_bulk_callback - urb stopped: -32
Feb 20 05:41:38 VDR kernel: [24738.194681] usb 9-8.3: USB disconnect, device number 6
Feb 20 05:41:38 VDR kernel: [24738.196802] usb 9-8.3: failed to send control message: -19
Feb 20 05:41:38 VDR kernel: [24738.197011] ch341-uart ttyUSB1: ch341-uart converter now disconnected from ttyUSB1
Feb 20 05:41:38 VDR kernel: [24738.197032] ch341 9-8.3:1.0: device disconnected
Feb 20 05:41:38 VDR kernel: [24738.397786] usb 9-8.3: new full-speed USB device number 7 using xhci_hcd
Feb 20 05:41:38 VDR kernel: [24738.487325] usb 9-8.3: New USB device found, idVendor=1a86, idProduct=7523
Feb 20 05:41:38 VDR kernel: [24738.487334] usb 9-8.3: New USB device strings: Mfr=0, Product=2, SerialNumber=0
Feb 20 05:41:38 VDR kernel: [24738.487339] usb 9-8.3: Product: USB2.0-Serial
Feb 20 05:41:38 VDR kernel: [24738.488448] ch341 9-8.3:1.0: ch341-uart converter detected
Feb 20 05:41:38 VDR kernel: [24738.490083] usb 9-8.3: ch341-uart converter now attached to ttyUSB2
Feb 20 05:41:38 VDR mtp-probe: checking bus 9, device 7: "/sys/devices/pci0000:00/0000:00:15.0/usb9/9-8/9-8.3"
Feb 20 05:41:38 VDR mtp-probe: bus: 9, device: 7 was not an MTP device
Wird da per CRON regelmäßig lang laufenden Prozessen der Garaus gemacht?
An ttyUSB1 hängt mein Arduino. Ich habe sowieso immer mal das Problem, dass nach etlichen Stunden das Bild schwarz ist. Das OSD tut dann noch und nach einem Restart des VDR (nicht des ganzen Systems) ist alles wieder ok. Vielleicht hat das ja die selbe Ursache. Der TeVii-Tuner ist auch ein USB Device.

Hoffnungsvolle Grüße,
Uwe
Test-VDR: Asrock J4205, 4GB RAM, 30GB SSD, Cine S2 PCIe twin Tuner + DuoFlex an Durline UK119 SCR LNB
gb  20.Feb.2018 23:11:43
Hallo Uwe
Ich habe sowieso immer mal das Problem, dass nach etlichen Stunden das Bild schwarz ist. Das OSD tut dann noch und nach einem Restart des VDR (nicht des ganzen Systems) ist alles wieder ok. Vielleicht hat das ja die selbe Ursache. Der TeVii-Tuner ist auch ein USB Device.
Es sieht ganz danach aus, das deine TeVii mit dem selben Problem kämpft.
Vielleicht hast du ein Hardware Problem, auch mal das BIOS vom Motherboard nach Einstellmöglichkeiten durchkämmen.

Das der Cronjob dir einfach die USB Devices killt, ist mir nicht geläufig, aber auch nicht unmöglich.

Da bin ich leider auch ein wenig überfragt.

Gruß Aaron



Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
gb  21.Feb.2018 06:40:09
Guten Morgen Uwe

Ich benötige mal noch die Ausgabe von "lsusb"

Bei deinem Log Schnipsel wird von einem Verbindungsabbruch USB Device 6 gemeldet, dieser war bis zu dem Zeitpunkt an ttyUSB1. Kurz darauf wird dieser reconnected als USB Device 7 an ttyUSB2.
Ursache könnte zB mangelhafte Stromversorgung sein.

Mann könnte da mit einer Rules versuchen das Gerät auf ein ttyUSBxx fest zu bannen, eventuell hilft es ja.

Eine Problemlösung ist es dann jedoch nicht, eher eine Problem Umschiffung.
Auch verstehe ich nicht ganz, warum hyperion ng bei dir dann auf 100% zieht, das ist neu.

Gruß Aaron


Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
zzzözzz  21.Feb.2018 16:24:58
>> Im normalen Betrieb läuft alles. Ich schalte dann den Fernseher und die LED-Stromversorgung aus.

Du schaltest die LED Stromversorgung aus, vllt ist genau das die Ursache: irgendwohin fließt Strom der so nicht fließen soll.
Falls das so ist, lässt sich das nur mit Gesamt-Schaltplan verstehen.
gb  21.Feb.2018 18:27:02

Du schaltest die LED Stromversorgung aus, vllt ist genau das die Ursache: irgendwohin fließt Strom der so nicht fließen soll.

Falls das so ist, lässt sich das nur mit Gesamt-Schaltplan verstehen.
Sollte eigentlich nicht so sein

Siehe Plan:
https://uploads.tapatalk-cdn.com/20180221/994f39c787e99a248ac3fd9c7f9a0a31.jpg

Der Arduino sollte nicht an die 5V des Netzteils angeschlossen werden, von daher ist da eigentlich eine Trennung vorhanden. Was sein kann, das der gemeinsame Null irgendwo ein Potenzial bekommt.

Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
zzzözzz  21.Feb.2018 18:43:38
[quote='gb' pid='180138' dateline='1519234022']

Du schaltest die LED Stromversorgung aus, vllt ist genau das die Ursache: irgendwohin fließt Strom der so nicht fließen soll.

Falls das so ist, lässt sich das nur mit Gesamt-Schaltplan verstehen.

Sollte eigentlich nicht so sein




Hmm.., machen wir mal Elektronik für Anfänger.

Der Arduino wird nur vom USB-Port gespeist und hat einen Ausgang zum Eingang der LEDs (WS2812/11 ?)..
Ist das Netzteil der LEDs aus, fließt nun aus dem Ausgang des Arduino Strom in den Eingang des ersten Chips der LED Kette  über dessen (echte oder parasitäre) Diode zu den +5V der LED Chips. Unser armer kleiner Atmega Ausgang versucht nun also aus dem USB Port eine ewig lange LED Kette mit Strom zu versorgen..? Das wird nix.

Zwischen den Ausgang des Arduino und den Input der Kette muss ein Widerstand oder ähnliches Bauteil was den Strom im Falle des Ausfalls der Versorgung der LEDs auf ein Maß reduziert,. was sowohl der Atmega auf dem Arduino als auch der USB Port auf Dauer sicher treiben können. Alternativ darf der Arduino nie im USB stecken.
gb  21.Feb.2018 19:16:23
Hi Wirbel
Hmm.., machen wir mal Elektronik für Anfänger.
Hat's doch noch einer geschafft mich zum Feierabend zum schmunzeln zu bringen :)


Der Arduino wird nur vom USB-Port gespeist und hat einen Ausgang zum Eingang der LEDs (WS2812/11 ?)..
Ja, das Schaltbild ist doof, aber ich hatte bisher keine Zeit um das zu überarbeiten.
Eigentlich ist das howto für APA102C oder ws2801 also 4 Draht. Spannung und 2 Draht Daten Ck/SI


Ist das Netzteil der LEDs aus, fließt nun aus dem Ausgang des Arduino Strom in den Eingang des ersten Chips der LED Kette  über dessen (echte oder parasitäre) Diode zu den +5V der LED Chips. Unser armer kleiner Atmega Ausgang versucht nun also aus dem USB Port eine ewig lange LED Kette mit Strom zu versorgen..? Das wird nix. in der Theorie kann ich deine Bedenken nachvollziehen, rein praktisch allerdings nicht prüfen, mein Werkzeugkoffer mit Messutensilien steht in der Firma.

Allerdings hab ich so meine Bedenken, denn ich hab ein kleines Netzteil am Motherboard ( 250-300 weiß ich jetzt nicht genau ) und das Netzteil der 128 LEDs auch mal den ganzen Tag nicht an. Solch ein Verhalten hatte ich jedoch noch nicht.

Wie gesagt müsste man mal messen.

Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)
videopix  21.Feb.2018 22:06:03
Also,

erstmal die Ausgabe von lsusb:
Bus 009 Device 005: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 009 Device 018: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 009 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 009 Device 002: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 009 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 010 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 9022:d660 TeVii Technology Ltd. DVB-S2 S660
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 9022:d660 TeVii Technology Ltd. DVB-S2 S660
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Der Übeltäter steht in Zeile 2. Die Device-Nummer wird nach jedem Verbindungsabbruch eins hoch gezählt.

Die Schaltung ist genau so wie oben beschrieben: Der Arduino hängt über ein USB-Kabel vieradrig am PC, bekommt seine Spannung also von dort. Masse Clock und Data gehen an die LED-Kette und +5V und Masse von dort ans LED-Netzteil. Aus- und Einschalten hat keine Auswirkung. Ich sehe da kein Problem.

Alle paar Stunden verliert das USB-Device seine Verbindung. Kann gut sein, dass es am USB-Kabel liegt. Ich habe es jetzt versuchsweise mal durch ein besseres und wesentlich kürzeres mit Entstör-Ferritring ersetzt und beobachte die Sache.

Die Vermutung, dass der CRON-Job Schuld sein könnte hat sich zerschlagen. Das war nur in wenigen Fällen so und wohl nur Zufall.

Bin gespannt,
Uwe
Test-VDR: Asrock J4205, 4GB RAM, 30GB SSD, Cine S2 PCIe twin Tuner + DuoFlex an Durline UK119 SCR LNB
zzzözzz  22.Feb.2018 10:14:04
Wie auch immer, der/die IC-Eingäng(e) der LEDs müssen falls das Netzteil der LEDs aus ist geschützt werden.
Sonst stirbt mal einer der beiden, der Atmega oder der erste Chip der Kette.

Der Atmega Ausgang kann 40mA / 4.5V liefern, die interne Schutzdiode würde etwa 0.85V verlieren.
Mit jeweils Rv = (4.5-0.85)V / 40mA -> 100 Ohm wärst du also auf der sicheren Seite.

Der Nachteil, das bildet dann einen Tiefpass erster Ordnung mit der Eingangs- und Kabelkapazität. -> möglichst kurze Entfernung zur LED Kette wählen.
videopix  22.Feb.2018 12:12:18
Die LED-Kette hat schon Längswiderstände von 100 Ohm drin für Clock und Data vor dem ersten Chip.
Mein Problem ist genau die Entfernung. Zwischen dem VDR und dem Fernseher sind etliche Meter. HDMI hat kein Problem. Bei den LEDs bleibt mir die Wahl zwischen langem USB und kurzem LED-Kabel oder umgekehrt. Die Frequenz auf dem LED-Kabel müsste deutlich höher sein. Oder ich trenne den USB-Serial-Adapter vom ATMEGA ab und gehe seriell über die längste Strecke. Eine Alternative wäre noch ein ESP8266 über UDP. Aber der ballert mir dann das WLAN zu, zumal der VDR ja immer läuft.

Grüße, Uwe
Test-VDR: Asrock J4205, 4GB RAM, 30GB SSD, Cine S2 PCIe twin Tuner + DuoFlex an Durline UK119 SCR LNB
zzzözzz  22.Feb.2018 16:27:16
Ein langes USB Kabel bedeutet auch Probleme.

Wie wäre es mit RS485 zwischen Arduino und LEDs? z.B. 2 Stück davon

https://www.ebay.de/itm/TTL-RS-485-Konverter-Modul-Max485-Adapter-Bus-Modbus-Arduino-Raspberry-Pi/252712534559?hash=item3ad6d7421f:g:FQwAAOSw1cNaD3It
videopix  25.Feb.2018 16:31:12
Hallo Aaron,

wie wäre es möglich, zwei Instanzen von Hyperion NG zu starten? Wenn ich es richtig verstehe, kann dann jede Instanz ein separates Ausgabe-Device steuern.

Und nochwas: Laut System > Update im Web Interface läuft bei mir Hyperion 2.0.0, es gibt aber auch eine Version 2.1.0 mit Bugfixes.
Weißt du, wo man die bekommt?

Schönes WE,
Uwe
Test-VDR: Asrock J4205, 4GB RAM, 30GB SSD, Cine S2 PCIe twin Tuner + DuoFlex an Durline UK119 SCR LNB
gb  26.Feb.2018 06:44:59
wie wäre es möglich, zwei Instanzen von Hyperion NG zu starten? Wenn ich es richtig verstehe, kann dann jede Instanz ein separates Ausgabe-Device steuern.

Habe ich ehrlich gesagt noch nicht gemacht und wüsste auch kein praktisches Anwendungsbeispiel.

Probieren kannst du das, in dem du wartest, bis dein vorhandenes Hyperion Ambilight funktioniert. Dann müsstest du dem momentanen hyperion Webfrontend einen anderen Port geben, da ja default 8090 vergeben wird.

Dann Konsole auf und mal folgendes eingeben:

DISPLAY=:0 /usr/local/bin/hyperiond --rootPath /etc/hyperion hyperionNG_1.config.json
Sollte das funktionieren müsste ein default konfigurierter hyperion auf 8090 aktiv sein und auf deinem eigenen eingestellten Port der aktive hyperion.

Da könnte man dann auch was für bauen.


Und nochwas: Laut System > Update im Web Interface läuft bei mir Hyperion 2.0.0, es gibt aber auch eine Version 2.1.0 mit Bugfixes.

Weißt du, wo man die bekommt?
Da hyperion ng noch pre Alpha ist, gebe ich nicht viel auf die Versionsnummer. Ist glaube ein Bug..

Es gibt kein PPA, also kann man sich neuere Version nur per gitclone holen und neu bauen. Wie du es ja schon mit der vorhandenen Version gemacht hast.

PS: Neuere Version kann jedoch bedeuten, das deine bisherigen gemachten Einstellungen in der
/etc/hyperion hyperionNG.config.json nicht alle importiert werden können und du einiges neu konfigurieren kannst.

Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel(R) G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

[spoiler=(weitere easyVDR)]
easyVDR3.0(4.2.0 32-Bit) N4l-VM DH DualCore Asus Motherboard mit Intel(R)T2400 @1.83GHz 2GB DDR2, GT218 (rev a2),  Panasonic UJ-825-B Notebook DVD Brenner adaptiert auf IDE, LCD+IRTrans-Empfänger, 250GB Samsung 840 SATA SSD 2,5",Skystar S2 DVBS2 PCI, Avermedia AVerTV A835 HD USB DVB-T (ID 07ca:b835)